Great news: I found that my Latitude control panel actually has a nice touchpad device screen that let me disable it completely. So no more jumping around while typing because a thumb hit the touchpad.

Now, if I could just remember how to spell....